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Within People-Trak, a document is defined as a template (or document design) and a query. 

The template determines what the document looks like and the query determines which 

records are to be included. Depending on the type of document, the template may be created 

separately from the query or at the same time.  

Template Types 

People-Trak supports the different template types listed below. Template types are set when 

the template is created. 

 Email 

 Label 

 Letter 

 

Email 
An email template is merged with a record or record group to create a specific group of 

emails. The same email template can be used over and over with different record groups to 

produce any desired group of emails. When the Email Templates option is selected on the 

Templates menu, Email Templates screen is displayed. Use the Edit Template option on the 

File menu or the Edit Template button on the Tool Bar to access the Email Template Editor, 

which uses the standard Text Editor interface.   

Label 
A label document combines a label template and a query to produce a set of labels for a 

specific purpose. The same label template may be used with a different query to produce a 

different set of labels. Thus, you can create multiple documents with the same label template. 

When the Label Templates option is selected on the Templates menu, the Label Templates 

screen is displayed. Use the Edit Template option on the File menu or the Edit Template 

button on the Tool Bar to access the Label Template Editor, which uses the standard Text 

Editor interface. When the label template itself is created in the Text Editor, the size of the 

edit space is determined by the specifications of the label. For example, if you are creating a 

1-inch by 4-inch label, the size of the edit area in the editor will be 1 inch by 4 inches. 

Letter 
A letter document combines a letter template and a query to produce a set of letters for a 

specific purpose. The same letter template may be used with a different query to produce a 

different set of letters. Thus, you can create multiple documents with the same letter template. 

When the Letter Templates option is selected on the Templates menu, the Letter Templates 

screen is displayed. Use the Edit Template option on the File menu or the Edit Template 

button on the Tool Bar to access the Letter Template Editor, which uses the standard Text 

Editor interface. 

System Templates 

This process on the Administration menu allows Administrators to create templates that use 

system fields, which can then be used across all modules. There are four types of templates as 

described in the sections below. An unlimited number of each of the four template types can 

be defined by the user.  The main System Templates screen is similar to the Letter Template 
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screen, except it includes a Template Type field. Each of these templates uses the standard 

text editor.  

Cover Sheet 
Cover Sheet templates are single page documents that are automatically pre-pended to 

documents when they run. The template enables you to create the cover sheet just the way 

you want it. When the Cover Sheet Template Editor opens, you are given the space for a full 

page and you can format as desired. You can include tables and pictures as well. Cover 

Sheets are assigned to a document under the Cover Sheet tab in Document Properties. 

Note: Cluster Reports are reports that are composed of a “cluster” of other reports. When the 

cluster is run, each report is run individually and then merged into a single final document. 

You can specify a cover sheet for the entire cluster and it will be at the front of the first 

document. However, if you have specified cover sheets for any of the individual documents 

in the cluster, these will also be included in their respective places. 

Email Closing 
Email Closing templates can be used when sending emails from within People-Trak. The 

Send Email screens used throughout People-Trak allows you to specify either a template 

(fully formatted as desired) or enter a basic block of text. Email Closing templates can only 

use text fields, so image fields such as logo and signature cannot be used. If you want to have 

more elaborate emails using those fields, use the Email Template feature on the Templates 

menu and assign an email template to an email rather than using the simple block of text 

closing. Email Closings are assigned in User Setup. 

Note: The Email Closing Template will always use fields related to the current user, even if 

the sender specified in the From field is different.  If a user wants a more fully formatted or 

specific email, they can use an email template instead which supports the full spectrum of 

HTML formatting capabilities. 

Header and Footer  
A number of the People-Trak document types (Adhoc Reports, Freeform Reports, Standard 

Reports, etc.) utilize a header and footer. The header currently includes the logo and three 

fields regarding the document itself: company name, document title and document comment. 

You are also able to specify where these two blocks are positioned. The Header Note can be 

placed in the third unused space. The Footer Note will always be placed in the center area. 

Headers and Footers are assigned to a document under the Annotations tab in Document 

Properties. 

System Template Editor  

Use the Edit Template option on the File menu or the Edit Template button on the Tool Bar 

to access the System Template Editor, which uses the standard Text Editor interface.  

Within the editor, there is a change in the ability to select mail merge fields. In these four 

template types, only the system merge fields can be used. These include many fields from the 

company and current user, but would not include anything from employee record, applicant 

record, etc because these are not relevant. Other than Email Closing template, it is possible to 

specify the field that represents the user signature and company logo. The user signature (and 

other user fields) would be taken from the User Table for regular HR users in People-Trak 

and would be taken from the Employee table for ESS users.  
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Text Editor 

The Text Editor is a powerful word processing tool that emulates many of the features in 

Microsoft Word. It is used for editing the following: 

 Email Templates 

 Label Templates 

 Letter Templates 

 HTML Text 

 

Editor Differences 

Each variation of the Text Editor is used for a different purpose.  

Email, Label and Letter Editors 
The Email, Label and Letter Editors have advanced editing capabilities and have features 

similar to Microsoft Word. All of the options described for the Text Editor are available in 

both editors, except where noted. 

HTML Editor 
The HTML Editor is used when editing text for a field or label requires more than the Simple 

Editor. For example, the Job Description field in the Position Control module uses the HTML 

Editor. The HTML Editor is also used when editing the HTMLabel object in a custom screen. 

With this editor, the Page Setup feature is not required because the text is not being formatted 

for printable pages. The entire Insert menu is not available because those options are not 

allowed. The entire Field menu is not required because you cannot insert fields into an 

existing field (the text that is being edited). The entire Table menu is not available because 

tables are not allowed.  

Editor Screen 

When the Edit Template option is selected in a template or the formatted text field editor is 

invoked, the Text Editor screen is displayed. Depending on how the editor was opened, 

certain features will be disabled or not visible at all. The descriptions that follow describe all 

features of the editor.  

Menu Bar 

The Menu Bar is displayed at the top of the editor form and functions like other menus in 

People-Trak. It contains a phrase for each of the Editor menus. When the mouse is clicked on 

one of these phrases, the corresponding menu is displayed. Each of the menus and their 

options are listed below. 

File Menu 

 Save 

 Page Setup  

 Print  

 Exit  

 

Edit Menu 

 Undo  
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 Redo  

 Cut  

 Copy 

 Paste 

 Select All 

 Edit Header 

 Edit Footer 

 Find  

 Replace 

 

View Menu 
This menu is only available when editing letter templates. 

 Page Layout 

 Draft 

 

Insert Menu 

 Break (only valid for Letter Templates) 

 Page Number (only valid for Letter Templates) 

 Date  

 Picture  

 

Field Menu 

 Insert Field  

 Delete Field  

 Change Field  

 Show Fields  

 

Format Menu 

 Font  

 Paragraph  

 Bullets and Numbering  

 Columns  

 Headers and Footers  

 Background Color  

 Text Color  

 

Table Menu 

 Insert Table  

 Insert Row (only available when in a table) 

 Insert Column (only available when in a table) 

 Delete Table (only available when in a table) 

 Delete Row (only available when in a table) 

 Delete Column (only available when in a table) 

 Select Table (only available when in a table) 

 Border (only available when in a table) 

 Table Properties  

 Show Gridlines  
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 Tool Bar 

 Save  

 Preview 

 Spell Check 

 Cut 

 Copy 

 Paste 

 Undo  

 Redo 

 Find 

 Insert Field 

 Insert Date  

  Insert Picture 

 Zoom Dropdown 

 Template Name 

 

Format Tool Bar 

The Format Tool Bar emulates many of the features in Microsoft Word. It allows you to 

quickly and easily edit fonts and font characteristics, as well as many other aspects of the 

document. 

Font Dropdown  
Allows you to change the font for the currently selected text. 

Bold  
Allows you to set or unset the bold attribute for the currently selected text. This is a state 

button. If the button is in the down state, the text has already been set to bold. 

Italic  
Allows you to set or unset the italic attribute for the currently selected text. This is a state 

button. If the button is in the down state, the text has already been set to italic. 

Underline 
 Allows you to set or unset the underline attribute for the currently selected text. This is a 

state button. If the button is in the down state, the text has already been set to underline. 

Left Justify 
 Allows you to left justify the currently selected text. This is a state button. If the button is in 

the down state, the text has already been left-justified. This is the typical default setting when 

you begin your document. 

Center Justify  
Allows you to center justify the currently selected text. This is a state button. If the button is 

in the down state, the text has already been centered. 

Right Justify 
 Allows you to right justify the currently selected text. This is a state button. If the button is in 

the down state, the text has already been right-justified. 
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Full Justify  
Allows you to full justify the currently selected text. This is a state button. If the button is in 

the down state, the text has already been full-justified. 

Enumeration  
Allows you to activate or deactivate the numbering format for the currently selected text. This 

is a state button. If the button is in the down state, the text has already been set to the 

numbering format 

Bullets  
Allows you to activate or deactivate the bullets format for the currently selected text. This is a 

state button. If the button is in the down state, the text has already been set to the bullets 

format. 

Indent Paragraph  
Indents the current paragraph. 

Outdent Paragraph  
Outdents the current paragraph. 

Highlight Color  
Allows you to choose the highlight color for the selected text. 

Text Color 
 Allows you to choose the font color for the selected text. 

Ruler 

The Ruler is located between the Format Tool Bar and the text area. The Ruler is used to 

view and to modify indents and tab stops with the mouse. These same settings can be 

changed manually using the Paragraph option on the Format menu. 

First Line Indent 
 The first line indent is denoted by a small triangle on the upper half of the Ruler. First line 

indents can be either left (less than) or right (greater than) of the left margin. When a 

paragraph is indented on the first line, the first line indent is to the right of the left indent. 

When bullets or numbering are used, the first line indent is left of the left indent to 

accommodate the bullet or number symbol. 

Left Indent  
The left indent is denoted by a small triangle on the lower half of the Ruler. The left indent 

can be moved independently of the first line indent. 

Right Indent  
The right indent is denoted by a triangle on the right-hand side of the Ruler. 

Tabs  
Tabs are denoted by the appropriate tab symbol on the Ruler. Left-click on the ruler to add a 

left-justified tab or right-click to add a right-justified tab. You can also set tabs using the Tabs 

option on the Format menu. 
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Status Bar 

The Status Bar is used to display information about the current cursor position and the current 

edit status. 

 

Section Counter  
Displays the current section number for your cursor placement followed by the total number 

of sections in the document.  

Page Counter  
Displays the current page number for your cursor placement followed by the total number of 

pages in the document. This section of the Status Bar is only visible in Page Layout mode. 

Line Counter  
Page Layout: Displays the current page line in relation to the current page your cursor is on. 

Therefore, as you page down, the Line Counter will start over at “1”. 

 

Draft: Displays the current line your cursor is on. There are no “pages” in this view, so the 

numbering just continues throughout the document. 

Column Counter  
Displays the current column of your cursor’s placement. 

Zoom  
Displays the current zoom percentage. 

Insert/Overstrike 
 Displays the current status of the insert/overstrike mode. If insert mode is active, the section 

displays “INS”. If the overstrike mode is active, the section displays “OVR”. 

Caps Lock Indicator 
 Displays the current status of the Caps Lock key. If Caps Lock is on, the phrase “CAPS” is 

displayed. Otherwise, the section is blank. 

Num Lock Indicator 
 Displays the current status of the Num Lock key. If Num Lock is on, the phrase “NUM” is 

displayed. Otherwise, the section is blank. 

Working with Images 

Inserting an Image 
Placing images in the Text Editor is quite simple. Use the Insert Picture option on the Insert 

menu or the Insert Picture button on the Tool Bar to activate the Select File popup. Use the 

Select File popup to locate the desired image file. When a file is selected, the image will be 

returned to the editor at the location of the cursor. 
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Moving and Sizing an Image 
Images can be moved and sized using the mouse. To move the image, simply click on the 

image and drag it to wherever you want. To size the image, click on the image and then click 

on any of the drag handles and drag in any direction. 

Deleting an Image 
An image can be deleted like any other character. Select the image by clicking on it. Then, 

press the DELETE key to delete the image. 

Headers and Footers 

Headers and footers are supported in the Letter templates only. They are used to specify 

sections at the top (header) or bottom (footer) of a document. Header and footer sections are 

text areas just like the main body of the document. The primary difference is that the header 

and footer sections repeat for each page of the document and do not need to be redefined on 

each page. Header and footers are normally used for document titles, page numbers, form 

numbers, dates, authors, or other information that needs to be repeated on each page.  

Header 
The header is located within the top margin. This is the space between the top of the physical 

page and the starting point for the text. The location of the header within the top margin is 

defined by the header margin. The header margin is set with the Page Setup option. The 

header margin is measured from the top of the physical page.  

The header margin and the height of the header should fit within the top margin you have 

defined. If not, the header text may run into the main text when you view or print the 

document. Also, when you define both your top margin and your header margin, you need to 

take into account the non-printable region of your printer. Most printers cannot print at the 

top edge of a sheet of paper. Thus, there is a section that can be “chopped off” if the main text 

or header text is allowed to start at the very top of the page.  

Footer 
The footer is located within the bottom margin. This is the space between the ending point of 

the text and the bottom of the physical page. The location of the footer within the bottom 

margin is defined by the footer margin. The footer margin is set with the Page Setup option. 

The footer margin is measured from the bottom of the physical page.  

The footer margin and the height of the footer should fit within the bottom margin you have 

defined. If not, the footer text may run off the page when you view or print the document. 

Also, when you define both your bottom margin and your footer margin, you need to take 

into account the non-printable region of your printer. Most printers cannot print to the bottom 

edge of a sheet of paper. Thus, there is a section that can be “chopped off” if the main text or 

footer text is allowed to flow into that area. 

How to View and Edit Headers and Footers 
Headers and footers can be viewed and edited in Page Layout mode. You can simply click in 

the header or footer area to edit each or use the Edit Header/Edit Footer options on the Edit 

menu. If you are in Draft mode when selecting those options, you will be automatically 

changed to Page Layout mode first. 

How to Insert a Page Number 
A page number can be inserted into a header or footer at any desired location. The page 

number automatically increments for each page when the document is viewed or printed 
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Working with Tables 

The Text Editor provides complete table support for creating grids that simulate the data 

entry screens showing rows and columns of data. 

Inserting a Table 
A table can be inserted at any point within a document, except within an existing table. To 

insert a table, use the Insert feature on the Table menu and select Table. The New Table 

Parameters screen is displayed. 

This screen is used to specify the rows and columns for the table that you wish to create. You 

do not have to get the exact number correct because these can be adjusted later. However, it is 

useful to get the number close.  

When you have specified the rows and columns, the table will be inserted as shown in the 

example below.  

 

 

In this case, the table was generated with two rows and two columns. 

Note that an additional caption row was added and that captions were inserted for you. This 

feature can speed the process of adding caption rows considerably. If you do not wish to have 

a caption row, use the Delete Cell option on the Table menu and then select Delete Rows to 

delete the caption row. 

Deleting a Table 
A table can be deleted at any time as long as there are no merge fields in any of the cells in 

the table. If there is text in the table, but no merge fields, the table can be deleted. To delete a 

table, select the table and then use the Delete Table option on the Table menu. 

Inserting and Deleting Rows 
Rows can be added to a table at any time. On the Table menu, select Insert Row Above or 

Insert Row Below option to indicate where the row is to be inserted. Rows can be inserted at 

any time whether or not text has been added to any of the cells.  

Rows can be deleted from a table at any time. On the Table menu, select Delete Row. If there 

is text in the row, it is deleted along with the row. If there are any merge fields in any of the 

cells in the row, the row cannot be deleted. You must delete merge fields individually from a 

row before the row can be deleted. 

Inserting and Deleting Columns 
Columns can be added to a table at any time. On the Table menu, select Insert Column to Left 

or Insert Column to Right option to indicate where the column is to be added. Columns can 

be inserted at any time whether or not text has been added to any of the cells. 

Columns can be deleted from a table at any time. On the Table menu, select Delete Column. 

If there is text in the column, it is deleted along with the column. If there are any merge fields 

in any of the cells in the column, the column cannot be deleted. You must delete merge fields 

individually from a column before the column can be deleted. 
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Resizing Columns 
Columns can be resized using the mouse. Click the mouse on the desired column line and 

drag the column to the left or right as desired. You can drag columns to any desired position 

with or without text in the columns. 

Working with Cells 
Each cell is a distinct section of a document. You can add text and format text within a cell 

completely independently of the text and formatting within another cell, even if a cell is 

within the same row or column. You can use the mouse or the tab key to move the cursor 

between cells. 

If the text of any cell on a row is wider than the space provided, the text will wrap and the 

row height for the entire row will be increased. One or more merge fields can be inserted into 

the cell as desired using the same techniques described in the section below 

Setting Background Colors 
You can set the background color for the whole table or any part of it by highlighting all or 

part of the table and clicking the Background Color button on the Tool Bar. You can then 

select the appropriate color you want to apply. 

Working with Merge Fields 

With the Email, Label, and Letter Template Editors, you can merge fields from the database 

with the text of your template to create powerful documents. When you generate an email, 

label, or letter, the actual values from the database are substituted in place of the merge fields 

and you have a document specific to the employee, applicant, etc., for whom it was produced. 

Inserting a Field 
You can insert any field from the database into any location in the template. Simply click in 

the desired location and then use the Insert Field option on the Field menu or the Insert Field 

button on the Tool Bar.  

Using Autoset 
After clicking OK on the Field Settings screen, People-Trak automatically detects that you 

are inserting fields into a table and displays the following prompt:  

Autoset the column? 

Upon selecting “Yes”,the entire column is populated with the specified field and the row 

modifiers are automatically sequenced from one to the highest numbered row in the table. 

You can check this by double-clicking on any of the fields. When the Field Settings screen is 

displayed, you can see that the both the Field Name and the appropriate Row Modifier have 

been supplied. 

Identifying Existing Fields 
Due to their length, field names are not actually entered into the document itself. Instead, a 

placeholder ~F~ is used. You can identify any single field by double-clicking on the field. 

The current field name and modifiers are displayed. 

You can identify all of the fields in the document at one time using the Show Fields option on 

the Field menu. This option will substitute the database field name for each of the ~F~ 

placeholders on the screen. You can use the Show Fields option again to restore the ~F~ 
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placeholders. If you save a document with the field names displayed, the document will be 

saved correctly, without the field names.  

Before 

 

After 

 

Previewing the Document with Fields Substituted 
When you are building a document with merge fields, you may wish to see what the 

document would look like when data is actually merged. On the File menu, select Preview or 

on the Tool Bar, click Preview. When this option is used, each field is filled with a string of 

“X” characters that is as long as the maximum number of characters allowed for the field. 

This will assist you in determining if you left enough space between columns and tabs. If the 

“X” characters overlap between two fields, it is possible that the fields are too close. 

 

If Preview is active and you use Preview again, the “X” characters will be removed and the 

template restored. If you save a document with Preview active, the document will be saved 

correctly, without the “X” characters.  
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System Category 
When inserting fields into a template, there is a System category provided on the Select Field 

popup screen. This category includes a list of the system variables that can be inserted. There 

are three types of fields in this category: company system variables, other system variables 

and user variables. 

Company System Variables 

The company related fields entered with the Enterprise Setup or Company Setup processes 

can be entered into documents using the variables listed below. When a document is printed, 

the data actually substituted will be for the currently active company.  

 Company Address 1 

 Company Address 2 

 Company City 

 Company Fax 

 Company Logo 

 Company Name 

 Company State 

 Company Telephone 

 Company Website 

 Company Zip 

 Federal Tax ID 

 Local 1 Tax ID 

 Local 2 Tax ID 

 Other 1 

 Other 2 

 Other 3 

 Other 4 

 State Tax 

 

Other System Variables 

 System Date  

 System Time  

 

User Variables 

The follow variables are taken from the similarly named fields that are maintained in the User 

Setup process. These variables reflect the currently logged in user. This is useful when the 

same document is to be used by multiple users, but is to be signed by the user actually 

producing the report. The name of the user actually producing the particular letter is 

substituted into the document. 

 User Email 

 User Extension 

 User Fax 

 User Name  

 User Signature 

 User Telephone  

 User Title 
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This lesson covers how to use the Explorer to create and modify templates. It also shows how 

to create documents from a template and a query as well as print labels for a group of 

employees during an editing session. The lesson concludes with a demonstration of how to 

copy a template. 

Tutorials 
Select and Modify an Existing Template: shows how to select an existing template and 

modify it. 

Create a Label Template: demonstrates how to create a new label template from scratch. 

Create and Print a Label Document: shows how to create a document from a label 

template and a query. Also demonstrates how to make a copy of a document. 

Print Labels for a Group: demonstrates how to print labels for a group of employees during 

an editing session. 

Copy a Template: shows how to copy an existing template and make changes to the new 

template copy. 
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Tutorial 1.1 – Select and Modify an Existing Template 

Within People-Trak, a document is defined as a template (or document design) and a query. 

The template determines what the document looks like and the query determines which 

records are to be included. In the tutorials in this lesson, we will be using label templates to 

demonstrate the basics of working with a simple template. These basics also apply to letter 

templates. We will use letter templates in the next lesson to show some advanced editing 

features. 

1. Start People-Trak by double-clicking on the People-Trak Trainee icon on your desktop 

(or as instructed).  

 

The Select Product Option screen is displayed.  

2. The Position Control and Attendance options should be the only options that are 

toggled on. If not select the Training button to select them. 

3. Click OK  

 

The Login screen is displayed. 

4. In the User ID field, enter DEMO. 

5. In the Password field, enter DEMO. 

 

The Organizer desktop is displayed with the Personnel Management module selected. 

 

Let’s take a look at label templates. 

6. On the Templates menu, select Label Templates. 

 

The Label Templates screen is displayed. Label templates are displayed in the list on the 

left. The details for the highlighted template are shown on the right. 

7. Select Address Label - Avery 5160 in the list of templates on the left.  

 

The standard settings for this label template are displayed on the right. We want to use 

the standard 5160 label, so we will leave these settings as is.  

8. On the File menu, select Edit Label Template or on the Tool Bar, click the Edit Label 

Template button to start the text editor. 

 

When the Label Template Editor screen is displayed, note that the edit area has been 

sized to match Avery 5160 label.  

 

This label contains no literal text. It contains only fields. The fields are indicated by the 

~F~ placeholders.  

9. Move the cursor over one of the placeholders.  

 

The cursor icon switches to an arrow whenever you hover over a placeholder. You can 

use this feature to identify (and to optionally change) an existing field in a template. Try 

it now.   
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10. Move the cursor over the first placeholder and then double-click.   

 

The Field Settings screen is displayed. It shows the name of the field and any applicable 

modifiers.  

11. Close the Field Settings screen and try another field. 

12. Close the Field Settings screen. 

 

You can also show all of the fields at once.  

13. On the Field menu, select Show Fields to display the field names.  

 

From the field names, it is clear that this is an address label.  

14. Select Show Fields again to change the field names back to placeholders.  

 

Now, let’s add the Country field to the label template. 

15. Click on the first line after the last placeholder.  

16. On the Field menu, select Insert Field or on the Tool Bar, click the Insert Field (~F~) 

button to start the insert.   

 

The Field Settings screen is displayed. 

17. In the Field Name field, select Country. Click OK to insert the field. 

 

The national address label has now been switched to an international address label. 

18. Close the Label Template Editor screen, saving your changes.  

19. Close the Label Templates screen, saving your changes. 

20. Continue with the next tutorial. 
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Tutorial 1.2 – Create a Label Template 

In the last tutorial, you learned how to view and modify an existing template. In this lesson, 

you’ll create a template from scratch. Let’s get started. 

1. On the Templates menu, select Label Templates. 

2. On the Tool Bar, click the New Template button.  

3. In the Template Name field, enter My Big Label Template. 

 

The Label Type field allows you to pick the specific label type you want to use. People-

Trak is shipped with many standard label types. If you need to add label types, you can 

do so using the Maintain Label Types utility. 

4. In the Category field, select the Personal category. 

5. In the Label Type field, select Avery 5164.  

 

This is a somewhat larger label. 

6. On the Tool Bar, click the Edit Label Template button to start the text editor. 

 

When the Label Template Editor screen is displayed, the edit area is sized to reflect the 

actual size of the label. 

7. Because this is a large label, change the Font Size to 14. 

8. Press ENTER twice to move the cursor down two lines. 

 

Now let’s insert a field. 

9. On the Field menu, select Insert Field or on the Tool Bar, click the Insert Field (~F~) 

button to start the insert.   

 

The Field Settings screen is displayed. 

10. In the Field Name field, select Full Name. Click OK to insert the field. 

11. On the next line, insert the Address 1 field. 

12. On the next line, insert the Address 2 field. 

13. On the next line, insert the City, State Zip compound field. 

14. To customize your large label, change the font attributes on the Address 1 field to Bold, 

Italic, and Underline.  

 

Remember, you can do this by highlighting the field and then setting the attribute. 

15. Finally, to show that a template can contain text other than fields, press ENTER several 

times and add a line at the very bottom of the label that says: Bottom of the label. 

16. Note: You will need to use the right arrow at the City, State Zip field to get past it if 

there is no blank line under it yet.  
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17. Close the Label Template Editor screen, saving your changes. 

18. Close the Label Templates screen, saving your changes.  

19. Continue with the next tutorial.  
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Tutorial 1.3 – Create and Print a Label Document 

Now that we have created a template, it is time to create a document that uses that template. 

1. On the Documents menu, select Labels.  

2. On the Tool Bar, click the New Label button to create a new document.  

3. In the Document Name field, enter Label Using Big Label Template. 

4. In the Explorer Category field, select any desired category. Set the Category field to 

Personal. 

5. In the Label Name field, use the popup button to select the My Big Label Template we 

just created.  

6. Leave the Sort fields blank for the moment. 

7. Now run the label.  

 

You should have multiple pages with four labels per page. Move through the pages and 

enjoy your big label. It is truly something “big”. 

8. Close the Document Viewer. 

9. In the Sort By 1 field, select Last Name.  

10. Now run the labels again. 

 

Your big labels are now listed in order by last name. That’s even a bigger 

accomplishment. 

 

Now, let’s add a query.  

11. On the Query tab, add the following equation, which will list those employees who 

have really big pay rates. 

 

Pay Rate           > 5000 

12. Run the report.   

 

The number of big labels is now smaller because there are fewer employees with pay 

rates greater than $5000. 

13. Close the Document Viewer and the Labels screen.  

 

Your “big” document should be highlighted in the Explorer.  

14. On the File menu, select the Copy Label option. 

 

There will now be an identical copy of the document with the phrase “-1” appended to 

the document’s name. 
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15. Open the copy and change the Document Name field to Label 2 Using Big Label 

Template. On the Query tab, change the equation to look for employees who have pay 

rates less than $5000.  

16. Run the document to test it.  

 

You now know how to create two separate documents that use the same template. 

Because a document is composed of a template and query, these are not the same 

document because they have a different query. You can create other documents that use 

your “big” template as well. Each document will be unique. 

17. Close the Document Viewer.  

18. Before closing the Labels screen, delete the query row on the Query tab and remove the 

Last Name sort on the Specification tab, saving your changes.  

19. Close the Explorer.  

20. Continue with the next tutorial. 
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Tutorial 1.4 – Print Labels for a Group 

As we just saw, labels and letters for all employees can be printed within the Explorer. They 

can also be printed for any single employee or for a group of employees during an editing 

session. Here's how.  

 

First, let’s select a group of records for which to print labels.  

1. Click the Open Employee shortcut and use the Lookup Employee screen to select 

employees with a Last Name that starts with B. If you wish, use the Edit Lookup 

option after that record group is open to customize the group to contain exactly those 

members for whom you wish to print a label. 

2. On the Category Bar, click the Category Documents button. 

 

The Documents for Personal Category screen is displayed. 

3. Select the Document Type column header, so that the documents are sorted by type. 

You should be able to easily locate our label now. 

4.  Select Label 2 Using Big Label Template.  

5. Click on the Select Group button, until the button below it reads Current Group. This 

will run the labels for all the employees you designated. (Current Record will only use 

the current record, and Use Query will use the query in the document.) 

6. Click the Run button to run labels for the group. 

 

The list of employees is processed and after a brief delay the Document Viewer will be 

displayed with your labels. There should be one label for each employee in the group. 

7. Close the Document Viewer.   

8. Close the Documents for Personal Category screen. 

9. On the Tool Bar, click the Close Employee button to close the current record group. 

 

The ability to perform group functions is available when transferring records, printing 

documents, and sending email. The process is the same. Once you have a group 

identified, you can select the appropriate option from the File menu or on the Tool Bar. 

From there, you will be prompted to perform the function for the current record or for 

the entire group.  

10. Continue with the next tutorial. 

  

Label 

option does 

not work 
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Tutorial 1.5 – Copy a Template 

There are times when you might want to copy an existing template and tweak it a bit. For 

example, you might want to print the same information as on an existing label, just on a 

larger label. Or you might want similar information on the same-sized label, but you want to 

change a few fields. In these cases, you would want to copy a similar template and make 

some adjustments. Let’s see how this works.  

1. On the Templates menu, select Label Templates. 

2. Select Address Label - Avery 5160 in the list of templates on the left.  

3. On the File menu, select Copy Label Template.  

 

A new template is created with the name of Address Label - Avery 5160-1. 

4. Change the Template Name to be My All-American Label. 

 

If you wanted to change the Label Type, you could. In our case, we want to keep the 

same label size and just change on a field on the label. 

5. On the File menu, select Edit Label Template or on the Tool Bar, click the Edit Label 

Template button. 

 

The text editor is opened and your new label template is displayed. 

 

We are going to remove the Country field we added earlier. 

6. Click anywhere on the Country field placeholder. On the Field menu, select Delete 

Field. 

 

The Country field is removed from the label. 

7. Close the Label Template Editor screen, saving your changes. 

 

Let’s delete the label template we just created.  

8. On the File menu, select Delete Template or on the Tool Bar, click the Delete 

Template button. Click Yes to delete the template. 

9. Close the Label Templates screen saving your changes. 

10. Continue with the next tutorial.  
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This lesson covers the advanced features of the Text Editor while creating a letter template. 

This includes headers and footers, images, and tables. 

Tutorials 
Create a Letter Template: shows how to create a basic letter template. This includes setting 

page margins. 

Add a Header and Footer: demonstrates how to add a header and footer to a letter template. 

Insert an Image: shows how to insert one or more images into a letter template. 

Add a Table: demonstrates how to add a table to a letter template and how to add merge 

fields to the columns in the table. 
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Tutorial 2.1 – Create a Letter Template 

In the last lesson, you created a label template. In this tutorial, you are going to create a letter 

template. All of the advanced text editor features in this lesson also apply to label templates.  

1. On the Templates menu, select Letter Templates.  

2. On the Tool Bar, click the New Template button. 

3. In the Template Name field, enter My Special Letter. 

 

Like the Label Type field you learned about earlier, the Paper Size field allows you to 

pick the specific paper size you want to use. People-Trak is shipped with many standard 

paper sizes. If you need to add paper sizes, you can do so using the Maintain Paper Sizes 

utility. 

4. Leave the Paper Size field set to Letter. 

5. On the Tool Bar, click the Edit Letter Template button to start the text editor. 

 

When the Letter Template Editor screen is displayed, the editable area is shown in Page 

Layout view, which allows you to see the margins, header and footer. You have an 

option of changing to Draft view, which is sized like a word processor for full-page 

documents. We will stay in Page Layout view for our demonstration. 

6. On the Tool Bar, in the Percentage dropdown, select 75.  

 

The default page margins are one inch on all four sides. Note that the cursor is currently 

located one inch in from the top and left edges.  

7. On the File menu, select Page Setup. 

 

The Page Setup screen is displayed.  

8. Change the Top, Bottom, Left and Right margins to 1.50 inches. Click OK to make 

those changes to the page setup. 

 

The Ruler Bar is updated to reflect the new settings and the cursor is now 1.5 inches in 

from the top and left edges.  

 

When you first enter a new letter, the default Font is Arial and default Font Size is 11.  

9. On the Tool Bar, use the appropriate dropdowns to change the Font to Times New 

Roman and the Font Size to 12. 

10. Enter the following paragraph and press ENTER:  

 

This is my sample letter. In this letter, I will learn how to set margins, add a header 

and footer, insert images, and add tables.  

11. Continue with the next tutorial.  
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Tutorial 2.2 – Add a Header and Footer 

Headers and footers can only be viewed and edited when you are in Page Layout mode. You 

choose to edit a header or footer while in Draft mode, but you will be automatically switched 

into Page Layout mode to accomplish that. Let’s see how that works. 

1. On the View menu, select Draft.  

 

The letter is now shown in Draft mode. 

2. On the Edit menu, select Edit Header. 

 

The following message is displayed: 

Switching to Page Layout mode 

3. Click OK to close the message.  

 

The header area is outlined by dotted lines and includes ‘Header’ as the current text. 

This is a placeholder and you will need to change the header text to the desired phrase.  

4. Change the phrase from Header to Sample Letter.  

 

Whenever you are positioned to either the header or footer editing areas, the various 

editing and formatting options on the Tool Bar apply to the text in that area and not to 

the main editing area. So, if you wished to right justify the header (it is currently left 

justified), you can do so using the Right Justify button on the Tool Bar. Try it now. 

5. Click the Right Justify button to cause the phrase Sample Letter to be right justified 

within your header. 

6. Change the font attributes of the Sample Letter phrase to Bold and Underline using the 

appropriate buttons on the Tool Bar. (You will need to highlight the text first.) 

7. Return to the main editing area by clicking in that area.  

 

Any actions now performed using the Tool Bar buttons will apply to the main editing 

area. Now let’s add a footer. With the header or the footer, you can use the Edit Header 

or Footer options on the Edit menu, or you can just click in the header or footer areas. 

Let’s try the second option for editing the footer. 

8. Using the scroll bar, scroll down to the bottom of the letter. Click on the Footer text in 

the footer area. 

 

The footer area is now outlined by dotted lines to show that you are editing that area. As 

with the header, this is a placeholder that you can change to any desired phrase.  

9. Change the phrase to “Page:” including a space after the colon. 

 

Now we’ll see how to add page numbers to this footer (and thus to any header or footer 

you create). 

10. Verify that the cursor is just to the right of the “Page:” phrase. On the Insert menu, 

select Page Number. 
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You will see the number 1 displayed. The number 1 is not a literal; it is a variable. The 1 

is showing because you are on the first page of your letter. The number will 

automatically increment with each page of the letter. Now let’s format the page number. 

11. Highlight the footer text, and use the Font and Font Size dropdowns to change the Font 

to Times New Roman and the Font Size to 10. Then, highlight the page number portion 

of the phrase and make it Bold. 

12. Click in the main editing area.  

13. Continue with the next tutorial.  
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Tutorial 2.3 – Insert an Image 

An image can be inserted at any point in a document. Let’s see how to insert an image and 

also move it around. 

1. Click on the line just below the paragraph that you typed. 

2. On the Insert menu, click Picture.  

 

The Select File screen is displayed. This screen is used to select image files. 

3. In the PT9\SAMPLES directory of your local People-Trak drive, select the file named 

PETE&PETUNIA.JPG.  

 

The image contained in this file is displayed in your letter. It is a picture of our dear 

friend Pete the People-Stik with his gal Petunia!   

 

Once an image has been inserted into your letter, you can move the image around just as 

if it were a large character. For example, if you wish to move the image down, you can 

do so by inserting lines above the image. Try it now.    

4. Click on the line above the image and press ENTER a few times.  

 

Note that the image moves down.  

5. Now delete some of the blank lines and the image will move back up. 

 

The image can also be aligned just like text.  

6. Select the image by clicking on it. On the Tool Bar, click the Right Justify button to 

align the image with the right margin. Then click the Center button to align the image 

between the margins. Finally, use the Left Justify button to align the image with the left 

margin. 

 

The image can also be moved around with tabs.  

7. Click on the line immediately above the image. Then press DOWN ARROW to 

position the cursor to the image without actually selecting the image. Now press TAB to 

push the image to the right.  

 

The image will align with the next tab stop shown on the Ruler Bar. 

 

Now let’s see how to delete the image. 

8. Select the image by clicking on it. Then press DELETE and the image will be deleted. 

 

That’s all there is to deleting an image. 

9. Now, use the techniques used above to select the image again.  

10. Continue with the next tutorial. 
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Tutorial 2.4 – Add a Table 

A table can be inserted at any point in a document, except within an existing table. This 

tutorial will show you how to insert a table and then specify its contents. 

1. Click on the blank line below the image that you inserted in the prior tutorial.  

2. On the Table menu, select Insert Table to insert a new table.  

 

The Table Attribute screen is displayed. This screen is used to specify the number of 

rows and columns in the table. 

3. Specify 10 Rows and 4 Columns, and click OK. 

 

When you have specified the rows and columns, the table will be inserted into the letter. 

Note that an additional caption row was added and that captions were inserted for you. 

This feature speeds the process of adding caption rows considerably.  

 

We are going to create a Skills Inventory table on this letter. 

4. Change the captions to the following phrases: Skill Desc, Skill Date, Skill Level, and 

Skill Comment. In addition, change the alignment of the caption phrases from Left 

Justified to Centered. You can do this one caption at a time or you can select the entire 

caption row and do it all at once. 

 

Now we need to insert the merge fields. This looks like a daunting task as there are 40 

separate fields to insert, but there is a very nice feature in People-Trak that will make 

this task quite easy.  

5. Click in the first column of the first blank row. On the Field menu, select Insert Field 

or on the Tool Bar, click the Insert Field button to display the Field Settings screen. In 

the Field Name field, use the popup button to select the Skill Description field from the 

Training/Competency category.  

 

At this point, you would normally wish to specify a Row Modifier to indicate the first 

skill because this is the first row. However, you can take advantage of the “Autoset” 

feature within People-Trak by leaving the Row Modifier field blank.  

6. Click OK to close the screen. 

 

People-Trak automatically detects that you are inserting fields into a table and provides 

the following prompt:  

 

Autoset the column? 

7. Click Yes and see what happens. 

 

The entire column is populated with the Skill Description field and the Row Modifiers 

are automatically sequenced from one to the highest numbered row in the table.  

8. Check this by double-clicking on any of the fields.  

 

When the Field Settings screen is displayed, you can see that the both the Field Name 

and the appropriate Row Modifier have been supplied. 
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9. Repeat this process for the second column using the Skill Date field. Then complete 

column three using Skill Level and column four using Skill Comment. 

10. On the Field menu, select Show Fields. 

 

You can see all the Field Names and Row Modifier combinations that are inserted into 

the table. 

 

Now let’s see how this letter works. 

11. Close the Letter Template Editor, saving your changes. 

12. Close the Letter Templates screen, saving your changes. 

13. On the Documents menu, select Letters.  

14. On the Tool Bar, click the New Letter button.  

15. In the Letter Name field, use the popup button to select the My Special Letter we just 

created. 

16. Run the letter.  

 

You should see your header and footer, the image you inserted, and the Skills Inventory 

table you added. This letter, as you have created it, is not entirely useful unto itself, but 

you now know how to use many of the powerful features of the Letter/Label editor. 

17. Close the Document Viewer. 

18. Close the Letters screen. 

19. Close the Explorer.  

20. Continue with the next tutorial. 
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This lesson covers how to create system templates and add them to documents. This includes 

cover sheets and header and footer annotations. It concludes by demonstration how to modify 

an existing email closing template. 

Tutorials 
Creating an Attendance Report: reviews creating an adhoc report with a query statement. 

Creating a Cover Sheet: demonstrates how to create a cover sheet using the System 

Templates Editor 

Creating Annotations: shows how to create header and footer annotations using the System 

Templates Editor. 

Adding System Templates to a Document: shows how to add System Templates to a 

document using the Document Properties screen. 

Creating an Email Closing: shows how to create an email closing using the System 

Templates Editor. 
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Tutorial 3.1 – Creating an Attendance Report 

As you have previously learned, creating a report is a much more efficient way to gather 

information about employees as opposed to going through individual records.  

In this case, we want a list of employees who have breached the company attendance policy 

by using more than 40 hours from their illness account. First, we need to make a few changes 

to ensure that we do indeed have violators. 

1. Open up Julie Carrington’s record and view her Attendance screen. 

2. Find the Illness account row and in the Current Used column, change the amount to 41 

and save your change. 

3. Repeat the same steps in Donald Stern’s record, changing the amount to 44. 

4. Close Donald’s record, saving your changes. 

5. Create a new Adhoc Report and name it Illness Account Overage. 

6. For the Explorer Category and Category, select Attendance. 

7. Select the Report Definition tab and select the following fields for our report:  

Full Name 

Attendance Account 

Hours Used 

8. On the Full Name field, select a Sort Type of Eject so that we can see each employee 

on their own page of the report. 

9. For both the Attendance Account and Hours Used fields, select a Row Modifier of 2, 

so that we are pulling data from the hours that have been used in the employee Illness 

account. 

10. On the Query tab, enter the equation shown below, using the same Row Modifier of 2 

that our report definition had: 

 

Hours Used 2         >     40 

11. Run the report and examine the evidence. 

It looks like we have a few violations on our hands! 

12. Save your changes and close all screens.  

Despite the fact that the data is all there, this attendance report could use more 

substance. If it was placed on a manager’s desk as is, much would be left to the 

imagination as to what the report was for or what the next step would be. We will create 

a cover sheet for this very purpose in the next tutorial. 

13. Continue with the next tutorial. 
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Tutorial 3.2 – Creating a Cover Sheet 

1. On the Administration menu, select System Templates. 

At first glance, the System Templates screen is quite similar to the Letter Template 

screen, except it includes a Template Type field. In addition, all system templates use 

the standard text editor.  

2. Create a new System Template and give our new template the name Attendance 

Violation. 

3. In the Template Type field, select the popup to display the Select Template Type 

screen and select Cover Sheet. 

Cover Sheet templates are single page documents that are automatically pre-pended to 

documents when they run. This template enables you to create the cover sheet just the 

way you want it. For now, we will focus on creation and will show you how to add it to 

our report further on in the lesson. 

4. On the Tool Bar, click the Edit Template button to start the template editor and enter 

the following text: 

~F~ (insert Company Logo)  

According to ~F~ (insert Company Name) records, you have one or more employees 

in violation of company attendance policy. 

Please review the included report, follow the instructions provided on each page 

and return them to Human Resources.   

Thank You, 

~F~ (insert User Name)  

~F~ (insert User Title) 

You may have noticed that only the system merge fields were available to select from. 

Within system templates, you can select fields that pertain to the company and current 

user, but not anything from employee or applicant record because they would not be 

applicable here. 

5. Close the Cover Sheet Template Editor, saving your changes. We will remain in 

System Templates for the next tutorial. 

6. Continue with the next tutorial. 
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Tutorial 3.3 – Creating Annotations  

If you recall what our report looked like, there wasn’t a designated signature area. And we 

definitely do not want managers signing haphazardly wherever they choose. This issue can be 

solved by adding headers and footers, also known as annotations, to our attendance report.  

Let’s start by creating footer for employees to include their signature. 

1. Create a new System Template and name it Manager Signature. 

2. In the Template Type field, select Footer Note and start the template editor. 

3. Enter the following text: 

Manager Signature: _______________________________ 

4. Close the Footer Note Template Editor, saving your changes but remain in the System 

Template Editor. 

Just to make sure our managers understand the power of their signature on this report, it 

would be best to add a header with additional information. 

5. Create a new System Template and name it Attendance Acknowledgement. 

6. In the Template Type field, select Header Note and start the template editor. 

7. Enter the following text: 

By signing this report I acknowledge this employee’s attendance violation 

8. Save your changes and close all screens.  

9. Continue with the next tutorial. 
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Tutorial 3.4 – Adding System Templates to a Document 

With our cover sheet and annotations finished, we are ready to add them to our report and see 

how everything works together. 

1. Open the Adhoc Reports Explorer. In the Attendance category, find and highlight the 

Illness Account Overage report, but do not run it.  

2. On the Tool Bar, click the Adhoc Report Properties button.  

The Adhoc Report Properties screen is displayed with the tabs available for this report, 

most of them which you should recognize. Notice there is a Cover Sheet tab as well as 

one named Annotations that we have yet to explore. We are going to start by adding our 

cover sheet on the Cover Sheet tab. 

3. Select the Cover Sheet tab. 

4. In the Cover Template field, click the popup button. 

The Select Template screen is displayed. You will only see Cover Sheet templates that 

are available for use, one of them being the one we just created. Templates available will 

depend on the template type selected as you will see when we set the header and footer 

for this report. 

5. Select our Attendance Violation cover sheet and return to the Adhoc Report 

Properties screen.  

Now we can start to add some annotations. 

6. Select the Annotations tab. 

7. In the Header Template field, click the popup button and select the Attendance 

Acknowledgement header. 

8. In the Footer Template field, click the popup button and select the Manager Signature 

footer. 

For both the header and footer there are checkboxes that will repeat the header and 

footer on each page of the report when they are selected. If they are not selected, they 

will appear on the first page only. We want our header and footer on all pages. 

9. Select the Repeat Header and Repeat Footer checkboxes 

10. Save your changes, return to the document explorer and run our report. 

Our cover sheet shows up as the first page of our document and if we look through the 

actual report pages, we will see the headers and footers perfectly placed as if they had 

always been there. The report is ready for manager distribution! 

11. Continue with the next tutorial. 
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Tutorial 3.5 – Creating an Email Closing  

Email closings add a professional touch to email messages and For now are going to add 

some pizzazz to an existing email closing and see how to use the closing in a future 

lesson. 

1. On the Administration menu, select System Templates. 

2. Select Standard Email Closing in the list of templates on the left.  

3. On the File menu, select Edit Template or on the Tool Bar, click the Edit Template 

button to start the text editor. 

First, let’s take a look at what fields we will be working with. 

4. On the Field menu, select Show Fields to display the field names.  

The email closing already includes the name and title of the system user. We are going 

to go ahead and add the system user’s email address and phone number. 

5. Select Show Fields again to change the field names back to placeholders.  

6. Click on the first line after the last placeholder.  

7. On the Field menu, select Insert Field or on the Tool Bar, click the Insert Field (~F~) 

button to start the insert.   

 

The Select Field screen is displayed. 

8. Select User Email. Click OK to insert the field. 

9. On the next line, insert the User Telephone field. 

10. Close the Email Closing Template Editor screen, saving your changes.  

11. Close the System Templates screen, saving your changes. 

An email closing is assigned in User Setup for each user. Since we modified an existing 

template, all we need to do is confirm that it has been assigned to the DEMO user. 

12. On the Setup menu, select User Setup. 

13. Select the Preferences tab. 

It looks like the Standard Email Closing has already been assigned to the DEMO user, 

so no need for us to make changes.  

14. Close User Setup. 

15. Exit People-Trak. 

16. This concludes this tutorial and lesson. 
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Notes 
 


